Wise people learn when they can; fools learn when they must - Arthur Wellesley

Friday, 10 October 2014

Host Name Change in Solaris


HOSTNAME CHANGE

Well, we changed all network details of our system, but still we need to change the HOSTNAME,

For changing hostname we need to alter following files…

/etc/hosts
/etc/nodename
/etc/hostname.<name of primary interface>

Rename crash directory under
/var/crash/<hostname>
#mv <old name> <new name>


Use dumpadm to configure save core directory

dumpadm –s <new directory path>

change the Hostname in 

root@sol-test-1:>/#vi /etc/hosts
"/etc/hosts" [Read only] 6 lines, 97 characters
#
# Internet host table
#
::1     localhost
127.0.0.1       localhost
192.168.234.133 machine1        loghost


root@sol-test-1:>/#vi /etc/nodename
machine1

root@sol-test-1:>/#vi /etc/hostname.e1000g0
"/etc/hostname.e1000g0" 1 line, 11 characters
machine1

Going to
root@sol-test-1:>/#cd /var/crash/

root@sol-test-1:>/var/crash#ls -l
total 2
drwx------   2 root     root         512 Apr 25 03:35 sol-test-1

Changing the old name to new one

root@sol-test-1:>/var/crash#mv sol-test-1 machine1

root@sol-test-1:>/var/crash#ls -l
total 2
drwx------   2 root     root         512 Apr 25 03:35 machine1


root@sol-test-1:>/var/crash#cd machine1/


root@sol-test-1:>/var/crash/machine1#pwd
/var/crash/machine1


 Now check what is our DUMP setting,

root@sol-test-1:>/#dumpadm
      Dump content: kernel pages
       Dump device: /dev/dsk/c1t0d0s1 (swap)
Savecore directory: /var/crash/sol-test-1
  Savecore enabled: yes
   Save compressed: on

Well... it is configured with old Hostname, which needs to change

Let's configure the Dump with New Hostname

root@sol-test-1:>/#dumpadm -s /var/crash/machine1
      Dump content: kernel pages
       Dump device: /dev/dsk/c1t0d0s1 (swap)
Savecore directory: /var/crash/machine1
  Savecore enabled: yes
   Save compressed: on

Again verify the configuration

root@sol-test-1:>/#dumpadm
      Dump content: kernel pages
       Dump device: /dev/dsk/c1t0d0s1 (swap)
Savecore directory: /var/crash/machine1
  Savecore enabled: yes
   Save compressed: on

OK… NOW ALL SET,

Rebooted and

root@machine1:>/#who -b
   .       system boot  Oct 10 22:05

root@machine1:>/#hostname
machine1

root@machine1:>/#dumpadm
      Dump content: kernel pages
       Dump device: /dev/dsk/c1t0d0s1 (swap)
Savecore directory: /var/crash/machine1
  Savecore enabled: yes

   Save compressed: on


No comments:

Post a Comment